Key to

ALL ABOUT COMPUTERS

6
1. THE COMPUTER SYSTEM

A. 1. MICR reader  2. 3D Printer  
3. Antivirus software  4. Mobile Computer  
5. Plotter  

B. 1. operating system  2. Braille Embosser  
5. OCR Readers  


D. 1. Digital Projector  2. DTP  
5. Supercomputer  

E. 1. Norton Security, McAfee Secure  
2. Microsoft Word, LibreOffice  
3. Microsoft PowerPoint, LibreOffice Impress  
4. Microsoft Windows, Mac OS  
5. WinZip, WinRAR  

F. 1. Computers are broadly classified into four categories based on their size and processing power – microcomputers, minicomputers, mainframe computers and super computers.  
2. Input devices are used to input data and instructions into a computer. They accept input from the user and convert it into binary form that a computer can understand. After processing the input, a computer provides the result through output devices. Output devices take the data in the binary form from the computer and convert it into a form that a user can understand.  
3. Software which are provided free of cost to the user along with the source code are called open source software. Users also receive a license for the software which allow them to share the software, modify it and redistribute it to other users. Google Chrome and LibreOffice are two Open source software.  
4. (a) A Magnetic stripe card reader is an input device used to read information encoded in the magnetic stripe located at the back of cards such as credit cards, loyalty cards and membership cards. The magnetic
stripe card reader reads the information quickly and accurately when the card is swiped through it.

(b) An OMR reader is an input device used to scan and read special forms designed with boxes or circles which can be marked with a pencil or pen. It uses the light reflected from the form, for the absence or the presence of a mark. This information is converted into a computer readable file. It is usually used for scanning answer sheets of exams that have multiple choice questions.

(c) System software consists of the programs that control the operation of the computer system. It helps to manage and run the computer hardware in an efficient manner. It can be further classified into three categories:

i. Operating System

ii. Utility Software

iii. Language Processors

(d) An OCR reader is an input device used to scan printed text documents such as books and magazines and convert them into digital files that can be easily edited in a computer. Organisations use OCR to scan printed forms for automated data entry into a database in a computer.

(e) A Biometric device is an input device used to measure unique physical characteristics, such as finger print or iris pattern of a person. A record of these characteristics is stored in a database. The identity of a person can be determined by scanning the finger or eye and matching the results of the scan with records in the database. Biometric devices are used to mark attendance in offices and provide entry to authorized users. It is usually used for security purposes.

(f) A computer understands only machine language in the form of binary digits. A language processor is a system software that converts a program into machine language for a computer to execute it. Some examples of language processors are assembler, compiler and interpreter.
5. General purpose application software is used to perform some set of tasks for a large number of users, e.g. Word Processing Software, Spreadsheet Software and DBMS Software.

Customized application software is developed according to the requirements and objective of an organization. It is used to perform a specific set of tasks for the organization, e.g. ticket reservation system, payroll system and school management system.

### 2. COMPUTER LANGUAGES

A. 1. Interpreter  
   2. Machine Language  
   3. Assembly Language  
   4. High-level Language

B. 1. assembler  
   2. fourth  
   3. machine  
   4. Fifth

C. 1. T  
   2. F  
   3. T  
   4. T

D. 1. Features of Fourth generation programming language are:
   
   (a) It is closer to human language.
   
   (b) It is designed to reduce the overall time, effort and cost of software development.
   
   (c) It is much easier to use and it allows users or non-computer professionals to develop software.
   
   (d) It is usually limited to specific applications and may use syntax that is not used in other programming languages.

2. A compiler is a language processor that converts a high-level language program into a machine language program, in one go. It first scans the entire program and then translates into a machine language. A compiler also lists all errors in the program along with the line numbers on which errors have occurred. The translated program or object code produced by a compiler is stored in the computer.

An interpreter is a language processor that converts a high-level language program into machine language program, line by line. It reads a line of source code, converts it into machine code and executes it. If there
is an error in the code, the interpreter waits for the error to be corrected before proceeding. The object code produced by an interpreter is not stored in the computer.

3. **Assembly language** is the Second-Generation programming language. In this language, mnemonic codes are used to develop a program. Mnemonic codes are short words used for lengthy set of instructions. Programming in assembly language is simpler and less time consuming than programming in machine language. It is also easier to locate and correct errors in assembly language. Machine language is the first generation programming language. It is the only programming language that the computer can understand directly. It is expressed in the form of binary digits – 0 and 1. A program written in a machine language executes very fast because no translation is required. It is tedious, difficult and time consuming for a programmer to develop programs using machine language.

4. **High-level language** is also known as third generation programming language. It is a programmer-friendly and structured language, similar to English language. It uses English words and mathematical symbols to develop a program. High-level language programs are machine-independent programs written for one computer can be executed on another computer with minor changes or no changes at all. Some examples are C, C++.

5. A fifth generation programming language is an advanced high-level programming language. It provides a visual or graphical interface for developing a program. It is normally associated with the field of Artificial Intelligence. A fifth-generation language does not require reserve words, specialised syntax and coding. It allows the programmer to develop a program without having any specialised knowledge of the language. The programmer needs to know the problem to be solved rather than knowing how to solve it. Prolog and Mercury are examples of fifth-generation programming languages.
3. WORKING WITH APPS IN WINDOWS 10


B. 1. Calculator 2. Skip back
3. Snooze 4. Today


D. 1. You can convert quantities from one unit to another using the calculator app. To perform conversions:
   (a) Click the Menu button.
   (b) In the menu, under CONVERTER, click the quantity you want to convert from one unit to another.
   • The app screen displays two units for the selected quantity.
   (c) Click the units down arrow and select the required units for conversion.
   (d) Click various number buttons to enter the value for the first unit.
   • The Converter displays the equivalent value for the second unit.

2. To add a new alarm in the Alarms & Clock app:
   (a) On the Alarm tab, click the New + button at the bottom of the Alarms & Clock window.
   • The NEW ALARM screen appears.
   (b) Scroll in the hour and minute panes to set the alarm time.
   (c) Click Alarm name and type a name for the alarm in the text box that appears.
   (d) Click under Repeats and select the days on which you want the alarm to play.
   (e) Click under Sound and select a sound for the alarm.
   (f) Click under Snooze time and select a time interval by which you want to delay the alarm before it plays again.
   (g) Click the Save button at the bottom of the screen. The Alarms & Clock app activates the alarm and adds it to the alarms list.
3. To add a new event in the Calendar app:
   (a) In the Calendar app, click the + New event button. The Untitled-Event-Calendar screen appears.
   (b) Type a name for the event in the Event name text box.
   (c) Type the location for the event in the Location text box.
   (d) Click the Start: Date picker and select the start date for the event.
   (e) Click the End: Date picker and select the end date for the event.
   (f) Specify the Start time and End time for the event in the respective time boxes.
   (g) Type a description for the event in the Event Description text box.
   (h) Click the Remainder box and select a time interval, before the event start time, at which you want the reminder to appear.
   (i) Click the Save and Close button.
   • The app saves the event and displays it in the calendar. A pop-up window appears at the time you have specified for the event reminder. You can either Snooze or Dismiss the reminder.

4. Various controls available for playing music in the Groove Music app are:
   (a) Scrubber bar – To play the song from a particular point of time.
   (b) Previous – To move to the song previous to the current song.
   (c) Play/pause – To play or halt the current song.
   (d) Next – To move to the song next to the current song.
   (e) Volume – To adjust the volume of the song.
   (f) Repeat all/one/off – To toggle between repeat all songs, repeat current song or no repeat.
   (g) Shuffle on/off – To toggle between random or sequential order of songs.
Think and Answer

1. To add video in the Movies and TV app:
   (a) Click the Settings button at the bottom left of the app window.
   • The Settings page opens.
   (b) Click Choose where we look for videos.
   • A pop-up screen appears. It displays the list of folders from where the app picks videos.
   (c) Click the Plus + button. The Select Folder dialog box opens.
   (d) Select the folder that contains the videos you want to add to the video list.
   (e) Click the Add this folder to Videos button.
   • The folder is added to the folder list.
   (f) Click the Done button. The Movies & TV app adds the videos from the selected folder to the videos list.

2. Prerna can do so with history button in the Calculator app.

4. TABLES IN WORD 2016

A. 1. Quick Tables 2. Thrice
    3. = MAX(Above) 4. Table grid 5. =
B. 1. table style 2. custom
    3. Distribute Rows 4. Merge Cells 5. numeric
D. 1. Different ways to insert a table with a predefined layout in Word 2016 are:
   (a) Table grid
   (b) Insert table
   (c) Draw table
   (d) Quick tables

2. To delete a row from a table:
   (a) Click a cell in the row you want to delete.
   (b) On the Table Tools Layout tab, in the Rows & Column group, click the Delete button.
   • A drop-down list appears.
   (c) Click Delete Rows to delete the row containing
the current cell. Word deletes the row as per your selection.

3. Splitting a cell means to split a single cell into two or more cells while merging of cell means to merge two or more cells into a single cell.

4. You can convert existing text into a table. The existing text should be separated into different parts by tab spaces, paragraph marks, spaces or any other character such as #, @ or $.

To convert existing text into a table:
(a) Type the given list of values separated by tab spaces.
(b) Select the list of values.
(c) On the Insert tab, in the Tables group, click the Table button.
   • The Insert Table menu appears.
(d) Click the Convert Text to Table option. The Convert Text to Table dialog box opens.
(e) Under Table size section, specify the number of columns you want in the table. The number of rows gets adjusted automatically.
(f) Click the OK button.
   • Word converts the selected text into a table.

5. To calculate the sum of values in a column in a table:
(a) Type the values in the cell of a column.
(b) Click the cell below the last value.
(c) On the Table Tools Layout tab, in the Data group, click the fx Formula button.
   • The Formula dialog box opens with the formula =SUM(ABOVE) in the Formula text box.
(d) Click the OK button.
   • Word calculates the sum of the specified group of values and displays the result in the selected cell.

6. To apply shading effect to a table:
(a) Select the cells to which you want to apply shading.
(b) On the Table Tools Design tab, in the Borders group, click the Borders down arrow.
   • A drop-down list appears.
(c) Click Borders and Shading.
   • The Borders and Shading dialog box opens.
(d) Click the Shading tab.
(e) Select a background color, style and pattern color from the Fill, Style and Color drop-down lists respectively.
(f) Click the OK button.
   • Word applies the shading effect to the selected cells.

Think and Answer
1. Mary should use Custom table option.
2. He can do so with SUM( ) Formula.

5. ADVANCED FEATURES OF WORD 2016

A. 1. Alt + Ctrl + D  2. Project

B. 1. Endnotes  2. Data source
   3. merge field  4. Page numbers  5. Show Notes


D. 1. To add date and time to Header in a document:
   (a) Double-click the header.
   • The cursor blinks in the header.
   (b) On the Header & Footer Tools Design tab, in the Insert group, click Date & Time button.
   • The Date & Time dialog box opens.
   (c) Click the required date and time format.
   (d) Click the OK button. Word inserts the current date and time in the header.
   (e) Double-click anywhere outside the header to return to the document.

2. Mail Merge is a feature in Word 2016 that allows you to quickly create multiple copies of document such as letters, email messages and envelops. The majority of the content in the copies remains the same but details are different, depending on the person to whom it is addressed.

The mail merge process involves the following overall steps:
(a) Set up the main document. The main document contain the text and graphics that are same for each copy of the document.
(b) Create a data source. A data source is a list of information, such as name, address or phone numbers, that varies in different copies of the document.

(c) Merge the data source and the main document. The data source is merged with the main document to create multiple copies of the document.

3. (a) Headers are the areas in the top margin that allows you to add text and graphics which needs to be repeated on each page of a document such as Chapter name, date and time.

Footers are areas in the bottom margins that allows you to add text and graphics which needs to be repeated on each page of a document such as page numbers.

(b) Footnotes and Endnotes are used to add explanations and comments about certain parts of text in a document. They can also be used to give reference for specific text in a document. Footnotes appear at the bottom of a page while, endnotes appear at the end of the document.

4. Steps of the Mail Merge Wizard in Word 2016:
   (a) On the Mailing tab, in the Start Mail Merge group, click the Start Mail Merge button.
      • A menu appears.
   (b) Click Step-by-Step Mail Merge Wizard...
      • The Mail merge pane appears on the right side of the document window. It lists the various steps of mail merge process.

Step 1 Choose the type of main document – letters, email messages, envelopes, labels or directory.

Step 2 Select a document to be used as the main document. You can use the current document, select a template or open an existing document.

Step 3 Select a data source. You can select an existing data source or create a new data source.

Step 4 Write your letter and insert merge field into it.

Step 5 Preview the merged copies of the document.

Step 6 The mail merge process is complete. You can print or edit the merged copies.
5. To insert an endnote in a document:
   (a) Click at the bottom in the document where you want to insert the endnote.
   (b) On the References tab, in the Footnotes group, click the Footnote & Endnote dialog box launcher button.
   • The Footnote and Endnote dialog box opens.
   (c) Under the Location section, click Endnotes Radio button.
   (d) Under the Format section:
   • Select a format for the reference mark of endnote from the Number format list.
   • In the Start at box, specify a value for the first reference mark.
   (e) Click the Insert button.
   • The cursor moves to the endnote at the end of the document.
   (f) Type the required text for the endnote.
   (g) Click anywhere outside the endnote area to return to the document.
   • Word inserts the endnote with the reference mark in the document.

Think and Answer
1. Alisha can use Header for Project name and Footer for page numbers.
2. Mukund can use Footnotes and Endnotes to do so.

6. ENHANCING PRESENTATIONS IN POWERPOINT

   A. 1. Speaker Icon 2. Entrance 3. Timing 4. Insert 5. 0.25 seconds
   B. 1. scrubber bar 2. Emphasis 3. Transition
      4. Rehearse Timings 5. Recording Slide Show
   D. 1. To apply a transition to a slide in presentation:
      (a) Select the slide to which you want to apply a transition.
      (b) On the Transition tab, in the Transition to This Slide group, click the More button.
The transition gallery appears. It displays various transition effects grouped under different categories.

(c) Click the desired transition effect.

The transition effect is applied to the slide and previewed on the screen. A star icon is displayed next to the slide thumbnail in the Thumbnails pane.

(d) Click the Effects Options button and select a variation for the transition effect from the list that appears.

PowerPoint applies the selected effect to the transition on the slide.

2. To insert a video file in a slide from the computer:

(a) On the Insert tab, in the Media group, click the Video button.

A menu appears.

(b) Click Video on My PC…

The Insert Video dialog box opens.

(c) Select the video file you want to insert.

(d) Click the Insert button.

The PowerPoint inserts the selected video file in the slide. An image of the video file with a control bar appears on the slide.

3. Various playback controls available for an audio file in a slide are:

(a) Volume. To change the volume of the audio.

(b) Start. To specify whether the audio file starts automatically or when the mouse is clicked.

(c) Play across slides. To Play the audio, even if you move to other slides.

(d) Hide during show. To hide the audio icon during the slide show.

(e) Loop until stopped. To replay the audio until it is stopped manually.

(f) Rewind after playing. To rewind the audio once it finishes playing.

4. The rehearse timings feature is used to practice a slide show to figure out how much time you need to present each slide. It helps you to ensure that the presentation finishes in a stipulated time period.
5. To record a Slide Show with timing and narration:
   (a) On the Slide Show tab, in the Set-Up group, click the Record Slide Show down arrow and click Start Recording from Beginning...
   • The Record Slide Show dialog box opens.
   (b) Tick mark both the options Slide and animation timings and Narrations, ink and laser pointer are enabled in the record slide show dialog box.
   (c) Click the Start recording button.
   • PowerPoint switches to the presenter view and starts the presentation.
   (d) Speak clearly into the microphone to record narration for the slide.
   (e) Click the Pen and Laser Pointer Tools button and select an option – Laser pointer, Pen or Highlighter to record ink and laser pointer gestures.
   (f) Click the Next button to move to the next slide.
   (g) To end your recording, click the End Slide Show button at the top of the screen.
   • PowerPoint records the slide show. A speaker icon and the various ink marks are displayed on each slide.
   (h) Run the slide show.
   • PowerPoint runs the automated slide show with animation timings, recorded narrations and ink and laser pointer gestures.

6. To add multiple animation effects on an animated object:
   (a) Select an object with an animation applied to it.
   (b) On the Animations tab, in the Advanced Animation group, click the Add Animation button. A menu appears.
   (c) Click the animation effect you want to apply. PowerPoint applies the new animation effect to the selected object and displays two numbers adjacent to the animated object.

**Think and Answer**

1. Select the Random transition effect, under Exciting category in the Transitions gallery.
2. Animation Tab, Timing Group, With Previous Option.
7. MORE ON EXCEL 2016

A. 1. Ctrl + Shift + ;  2. Fill handle

B. 1. AutoComplete  2. AutoFill
    3. Custom  4. formula  5. Redo


D. | A |   | A |   | A |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>11:45</td>
<td>1</td>
<td>ABC123</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>12:45</td>
<td>2</td>
<td>ABC124</td>
<td>2</td>
</tr>
<tr>
<td>3</td>
<td>13:45</td>
<td>3</td>
<td>ABC125</td>
<td>3</td>
</tr>
<tr>
<td>4</td>
<td>14:45</td>
<td>4</td>
<td>ABC126</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1</td>
<td>August</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2</td>
<td>September</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3</td>
<td>October</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4</td>
<td>November</td>
<td>4</td>
</tr>
</tbody>
</table>

E. 1. The AutoComplete feature in Excel 2016 allows you to quickly enter similar text in different cells of the same column. To use autocomplete feature:
   (a) Type the first few characters of the required text in a cell. As you type, Excel automatically suggests the remaining characters based on the text you have entered earlier in the same column.
   (b) Press enter to accept the suggestion else, type the required text.

2. To move the contents of a cell from one location to another:
   (a) Select the cell whose content you want to move.
   (b) On the Home tab, in the Clipboard group, click the Cut button to cut the contents.
       • A moving dashed outline appears around the selected cell.
   (c) Select the new location where you want to paste the content.
   (d) On the Home tab, in the Clipboard group, click the Paste button. Excel moves the contents of the selected cell to the new location.
   (e) Press the Esc key to deselect the cell.

3. Number data are values that consists of digits from 0 to 9 on which mathematical calculations can be performed. Excel aligns numbers with the right border of a cell.
   • Text data consists of alphabet, numbers or symbols on which mathematical calculations cannot be
performed. Excel aligns text data with the left border of a cell.

4. To create a custom list:
   (a) Type the required list of values in consecutive cells in a row or column.
   (b) Select the cells containing the values.
   (c) Click the File tab.
   (d) Click Options in the Backstage view. The Excel Options dialog box opens.
   (e) In the left pane of the dialog box, click Advanced.
   (f) In the right pane, under General section, click the Edit Custom Lists.. button. The Custom Lists dialog box opens.
   (g) Click the Import button. The list of values gets added to the Custom Lists box and the list items are displayed in the List entries box.
   (h) Click the OK button to close the Custom Lists dialog box.
   (i) Click the OK button to close the Excel Options dialog box.

5. To change the height of a row in a worksheet:-
   (a) Select the cells whose height you want to change.
   (b) On the Home tab, in the Cells group, click the Format down arrow.
   - A drop-down list appears.
   (c) Click the Row Height and specify a value in the Row height text box.
   (d) Click the OK button.
   - Excel changes the row height to the specified value.

**Think and Answer**

1. To insert a new column in a worksheet:
   (a) Select the column heading before which you want to insert a new column.
   (b) On the Home tab, in the Cells group, click the Insert down arrow. A drop-down list appears.
   (c) Click Insert Sheet Columns.
   - Excel inserts a new column before the selected column.
2. To delete rows or columns from a worksheet:
   (a) Select the row heading or column heading you want to delete.
   (b) On the Home tab, in the Cells group, click the Delete down arrow.
   - A drop-down list appears.
   (c) Click Delete Sheet Rows or Delete Sheet Columns. Excel deletes the selected row or column.

8. FORMATTING IN EXCEL 2016

D. 1. Cell formatting refers to format the appearance of cells in a worksheet. You can add a background color or border around the cells, align the cell contents horizontally or vertically, change the direction of the cell contents, wrap the cell contents to display in multiple lines, and merge the cells. To draw borders around a cell range:
   (a) On the Home tab, in the Font group, click the Borders drop-down arrow. A menu appears.
   (b) Under Draw borders, select a line colour and style for the border from the Line Color and Line Style sub-menu respectively. The mouse pointer changes to a pencil pointer.
   (c) Click and drag the pointer over a cell range to draw a border all around the range.

2. To add a background color to a cell range:
   (a) Select the cell range to which you want to add a background color.
   (b) On the Home tab, in the Font group, click the Fill Color down arrow.
   - A menu appears which displays swatches of various colors.
   (c) Click a color swatch in the Theme Colors or Standard Color palette. Excel applies the specified background color to the selected cell range.
3. To rotate the content of the cell clockwise by $60^\circ$:
   (a) Select the cell range whose orientation you want to change.
   (b) On the Home tab, in the Alignment group, click the Orientation button.
   - A menu appears
   (c) Click the Format Cell Alignment option.
   - The Format Cells dialog box opens.
   (d) In the Format Cells dialog box, on the Alignment tab, drag the Orientation Marker to $60^\circ$ or type $60^\circ$ in the Degrees spin box.
   (e) Click the OK button.
   - Excel changes the orientation of the cell contents to $60^\circ$.

4. To display text in multiple lines within a cell:
   (a) Select the cell whose text you want to display in multiple lines.
   (b) On the Home tab, in the Alignment group, Click the Wrap Text button.
   - Excel displays the contents of the selected cell in multiple lines.

5. Alignment refers to the placement of cell contents within the boundary of a cell. To align the contents of a cell at top right position:
   (a) Select the cell whose contents you want to align.
   (b) On the Home tab, in the Alignment group, click:
      1. Align right - to change the horizontal alignment of cell contents.
      2. Top align - to change the vertical alignment of cell contents.
   Excel aligns the cell contents to top right position.

6. Excel provides various options to format numbers. You can add a currency symbol to the number, display it as a percentage or fraction and add or remove decimal places in the number. This is called number formatting. Various options available in the number format list are:
   Accounting number format - To add a currency symbol and a decimal point to the number value.
Percent style - To multiply the number by 100 and display the number with a percentage sign.
Comma style - To add comma in a number as thousands separator.
Increase decimal - To increase the number of digits after the decimal point in the number.
Decrease decimal - To decrease the number of digits after the decimal point in the number.

Think and Answer
1. Manish can use Accounting Number Format to do so.
2. Font Style, Background Color, Accounting Number Format, Percent Style, Alignment.

9. INTRODUCTION TO SMALL BASIC


B. 1. operator 2. Assignment 3. constant 4. object 5. variable


D. 1. Small Basic is fun! 2. 29 3. 171 4. 2 5. Aditya, you are 15 years old

E. 1. IntelliSense is a feature in Small Basic that offers you suggestions while writing code. As you type the first few characters of the code, the IntelliSense list pops up and offers suggestions. Press the Up and Down arrow keys to scroll through the list of options. Press ENTER to insert the highlighted command into your program.
2. A variable is a location in the computer’s memory that has a name and stores data temporarily. The value of a variable can be changed during the execution of a program.

Rules for naming variables:
• A variable should be given a unique and meaningful name that helps you understand the purpose of the information stored in the variable.
• A variable name can include letters, digits, and the underscores (_).
• A variable name must start with a letter and should not be any keyword like If, For, Then, etc.
3. An expression in a program combines operators and operands (variables and constants). An expression having arithmetic operators results in a numeric value.

Arithmetic operators are used to perform arithmetic or mathematical calculations on numeric constants and variables. If there are more than one arithmetic operators in expression, Small Basic follows the given order of preference, for the operators, to evaluate the expression.

(a) Brackets ()
(b) Multiplication and division
(c) Addition and subtraction

If the expression has arithmetic operators of same preference, the expression is evaluated from left to right.

4. The TextWindow object provides various input and output methods. Four methods of TextWindow object are:

(a) WriteLine () - It displays text or number in the output window and shifts the cursor to the next line.
(b) Write() - It displays text or number in the output window and keeps the cursor at the end of the same line.
(c) Read() - It reads string values as input.
(d) ReadNumber() - It reads numeric values as input.

5. The conditional statement is used to execute a statement or a group of statements based on certain conditions. The conditional statement lets you check a condition and perform specific functions based on whether the condition is True or False. It is also called the Branching statement.

The If – Then – Else statement uses four keywords – If, Then, Else and EndIf. The syntax of this statement is:

If (test condition) Then
  <statements to execute if the test condition is true>
Else
  <statements to execute if the test condition is false>
EndIf
If the condition is True, the statements after Then are executed and if the test condition is False, the statements after Else are executed. After execution, the control is transferred to EndIf.

Think and Answer
1. Name = “Mary”
   Age = 12
   TextWindow.WriteLine(“Welcome ” + Name)
   TextWindow.WriteLine(“You are ” + Age + “ years old”)
2. (a) 25 - The number is divisible by 5 only.
   (b) 11 - The number is divisible by 5 only.
   (c) 30 - The number is divisible by 10 as well as 5.

10. INTRODUCTION TO PIVOT ANIMATOR

A. 1. animation  2. segments  3. .piv
   4. Onion Skin  5. File menu

B. 1. Origin   2. Stick Figure Builder
   3. Time-line  4. handles  5. segment

C. 


E. 1. Various control buttons in Pivot Animator are:
   (a) Delete figure.  (b) Edit figure type.
   (c) Center figure.  (d) Flip/mirror figure.
   (e) Figure color.  (f) Join/unjoin figure to another.
(g) Raise.    (h) Lower.
(i) Copy figure.    (j) Paste figure.
(k) Figure scale.    (l) Opacity.

2. A stick figure is the representation of a person, animal, alphabet, digit or object. Various parts of stick figures are - Origin handle or orange handle and segment handle or red handle.

3. To edit a stick figure:
   (a) Select the stick figure you want to edit.
   (b) Click the Edit Figure Type button. The Stick Figure Builder Window opens with the selected figure in the Editing area.
   (c) Use various tools to edit the figure as desired.
   (d) In the File menu, click Add to animation.
      • The Figure Name Dialog box opens.
   (e) Type a name for the figure and click the OK button. The edited figure appears in the Editing area of Pivot Animator window and gets added to the Figure Selector.

4. To add a background image to the animation:
   (a) On the Menu bar, in the File menu, click Load Background. The Open dialog box opens.
   (b) Select the image that you want to set as the background of the frame.
   (c) Click the Open button.
      • A warning message appears to let you decide whether to resize the animation to fit the image or not.
   (d) Click the Yes or No button as desired.
      • The selected image is added as the background of the frame.

5. To rotate a stick figure:
   (a) Press and hold the Alt key.
   (b) Click and drag any segment handle to rotate the stick figure around its original handle.

To move the stick figure:
   (a) To move an entire stick figure, click and drag the origin handle to the new position.
(b) To move a segment of the stick figure, click and drag the corresponding segment handle to the new position.

11. MORE ON PIVOT ANIMATOR

A. 1. sprites  2. AVI  3. Ctrl + A  
   4. File menu  5. Figure Scale box

B. 1. origin  2. Ctrl  3. sprite  
   4. Stick Figure Builder  5. Options


D. 1. To load multiple stick figures:
   (a) On the Menu bar, in the File menu, click Load Figure Type. The Open dialog box opens.  
   (b) Press and hold the Ctrl key.  
   (c) Click the figures you want to add to the animation.  
   (d) Click the Open button. Pivot animator loads all the selected figures, in the form of a stack, to the current frame of the animation. Use the origin handles of the loaded figures to reposition them.

2. To join two or more stick figures:
   (a) Select a figure you want to join to another figure.  
   (b) Click the Join/Unjoin button.  
      • All the handles of the other figures turn white.  
   (c) Click a white handle of the figure to which you want to join the origin of the selected figure.  
      • The selected figure gets moved to the clicked handle of the other figure. The handle at the join appears white indicating that it is joined.

3. To rotate and resize multiple stick figure:
   (a) Select the figures you want to rotate.  
   (b) Press and hold the Alt key.  
   (c) Click and drag a red handle of any one of the selected figures.  
      • Pivot animator rotates and resize the selected figures as desired.

4. A sprite can be created in paint or any other graphic software or downloaded from internet. Sprites are
images that can be moved around, scaled or rotated in the same way as a stick figure.

To load a sprite:
(a) On the Menu bar, in the File menu, click Load Sprite image. The Open dialog box opens.
(b) Click the sprite you want to load to the animation.
(c) Click the Open button.
   • Pivot animator loads the selected sprite to the current frame of the animation.

5. To export an animation:
(a) On the Menu bar, in the File menu, click Export Animation.
   The save as dialog box opens.
(b) Type a name for the file in the File name box.
(c) Click the Save as type box and select a format in which you want to export the file.
(d) Click the Save button. Depending on the file format you have selected, a dialog box opens that prompts you to set different options for exporting the animation.
(e) Set the options in the dialog box as desired and click the OK button.
   • Pivot animator exports the animation in the selected format.

Various formats available to export an animation in pivot animator are:
(a) GIF (Graphic interchange format)
(b) AVI (Audio video interleave) video
(c) Separate images

12. EMAIL

D. 1. Email or electronic mail is an electronic message sent form one computer user to another through internet.
Email is delivered almost instantly. It eliminates barriers of time and distance.

Email has several advantages over the traditional paper mail.

(a) Speed - Email is delivered extremely fast when compared to traditional mail. It can reach any part of the world in a fraction of seconds.

(b) Cost - Email can be sent to anyone, anywhere in the world free of cost.

(c) Content - Email can contain text and documents, images, audio files and video files as attachments.

(d) Eco friendly - Email is eco-friendly as you do not require paper to send it.

2. Every email account has a unique address, called its email address. An email address is made up of two parts – the username and the domain name, separated by @ symbol.

Username - It is the name selected by the user at the time of creation of the email account. The username can have alphabet, digits and some special characters. The username should not contain any spaces in it.

The symbol @ - It is pronounced as ‘at’. It is used to separate the username from the domain name in an email address.

Domain name - It is the address of the email service provider's website or mail server.

3. To compose and send an email using mail app:

(a) In the Mail app, click + New mail.

• A message window opens.

(b) In the To box, type the email address of the recipient.

(c) In the Subject box, type a short description of the email message.

(d) In the message area, type the message you want to send.

(e) Use the formatting options at the top of the window to format the message.

(f) Click the Send button. The Mail app sends your
email message. A copy of the sent email message is stored in the Sent Items folder.

4. To attach a file to an email:
   (a) Click the Compose button.
   • The New Message window opens.
   (b) Type the recipients address, subject of the email and the message.
   (c) Click the Attach files button. The Open dialog box opens.
   (d) Select the file(s) you want to attach and click the Open button. The selected files are uploaded as attachment to the email.
   (e) Click the Send button to send the email message with the attachment.

5. Email netiquettes refer to the rules that one should follow while composing or replying email messages. Some of these are:
   (a) Keep email message brief and to the point.
   (b) Use proper spelling, grammar and punctuation.
   (c) Do not send private or confidential information via email.
   (d) Use the subject field to indicate the content and purpose of an email.
   (e) Do not attach unnecessary files.

Think and Answer
1. Joy can email the pictures as attachments to his cousin.
2. Anna can use the Mail app to view her email.

**ASSESSMENT SHEET – 1**

1. (a) Biometric device (b) Assembly Language (c) Groove Music (d) Header (e) Timing
2. (a) Minicomputers (b) Fifth (c) Snooze (d) Merge Field (e) Scrubber Bar
3. (a) F (b) T (c) T (d) F (e) T
4. (a) 3D Printer (b) Digital Projector (c) Plotter
5. (a) WinZip, WinRAR (b) Prolog, Mercury (c) Smartphones, Tablets
6. (a) Microsoft Excel  (b) Groove Music  
(c) Custom Table  (d) Transitions  (e) Assembler

7. (a) Computers are broadly classified into four categories based on their size and processing power – microcomputers, minicomputers, mainframe computers and super computers.

Microcomputers - A Microcomputer is the smallest general purpose computer with a single microprocessor. Microcomputers are also called personal computers as they are designed to be used by one person at a time.

Minicomputers - A Minicomputer is a medium-size multi-user computer with more than one microprocessor. It can support about 200 users at the same time.

Mainframe Computer - A Mainframe computer is a large-size computer with multiple microprocessors for different tasks. It has large storage capacity with high processing speed. It is capable of supporting hundreds, or even thousand, of users simultaneously.

Supercomputers - A Supercomputer is huge in size with thousands of microprocessors. It is the fastest and the most powerful computer. It has extremely large storage capacity with very high processing speed. It can process trillions of instructions per second.

(b)(i) A compiler is a language processor that converts a high-level language program into a machine language program, in one go. It first scans the entire program and then translates into a machine language. A compiler also lists all errors in the program along with the line numbers on which errors have occurred. The translated program or object code produced by a compiler is stored in the computer.

An interpreter is a language processor that converts a high-level language program into machine language program, line by line. It reads a line of source code, converts it into machine code and executes it. If there is an error in the code, the interpreter waits for the
error to be corrected before proceeding. The object code produced by an interpreter is not stored in the computer.

(ii) An OMR reader is an input device used to scan and read special forms designed with boxes or circles which can be marked with a pencil or pen. It uses the light reflected from the form, for the absence or the presence of a mark. This information is converted into a computer readable file. An OMR reader has the advantage of being highly accurate, cost effective and capable of handling large number of documents in a short duration of time. An OCR reader is an input device used to scan printed text documents such as books and magazines and convert them into digital files that can be easily edited in a computer. Organisations use OCR to scan printed forms for automated data entry into a database in a computer.

(c) To Insert table with predefined layouts in a word document.

(i) Click at the location in the document where you want to insert the table.

(ii) On the Insert tab, in the Tables group, click the Table button.

• The Insert Table menu appears.

(iii) Click the Quick Tables option and select a required table design.

• Word inserts the table with the selected design.

(d) To add videos in the Movie & TV app:

(i) Click the Settings button at the bottom-left of the app window.

• The Settings page opens.

(ii) Click Choose where we look for videos.

• A pop-up screen appears. It displays the list of folders from where the app picks videos.

(iii) Click the plus button.
• The Select Folder dialog box opens.
   (iv) Select the folder that contains the videos you want to add to the videos list.
   (v) Click the Add this folder to videos button.
   • The folder is added to the folder list.
   (vi) Click the Done button.
   • The Movie & TV app adds the videos from the selected folder to the videos list.

(e) Mail Merge is a feature in Word 2016 that allows you to quickly create multiple copies of document such as letters, email messages and envelopes. The majority of the content in the copies remains the same but details are different, depending on the person to whom it is addressed.

The mail merge process involves the following overall steps:

(i) Set up the main document. The main document contain the text and graphics that are same for each copy of the document.

(ii) Create a data source. A data source is a list of information, such as name, address or phone numbers, that varies in different copies of the document.

(iii) Merge the data source and the main document. The data source is merged with the main document to create multiple copies of the document.

(f) To apply an animation effect to an object:

(i) Select the object on which you want to apply an animation.

(ii) On the Animations tab, in the Animation group, click the More button.
   • The Animation menu appears and displays various animation effects, grouped various animation effects, grouped under different categories.

(iii) Click a desired animation effect.
• The animation is applied to the selected object and previewed in the slide. A sequence number is added adjacent to the animated object. A star icon is displayed next to the slide thumbnails pane.

(iv) Click the Effect Options button and select a variation for the animation effect from the list that appears.

• PowerPoint applies the selected animation effect to the object in a slide.

---

**ASSESSMENT SHEET – 2**

1. (a) Ctrl + Shift + ; (b) Drafts (c) AVI  
   (d) .sb (e) Wrap Text

2. (a) netiquettes (b) Stick Figure Builder  
   (c) Sprite (d) variable (e) AutoComplete

3. (a) F (b) F (c) T (d) T (e) T

4. (a) 35 (b) 86 (c) 4144  
   (d) –81.5 (e) 13
   (f) The condition is false

5. (a) Merge & Center (b) AutoComplete (c) Alignment  
   (d) AutoFill (e) Orientation

6. (a) To create a custom list:
   
   1. Type the required list of values in consecutive cells in a row or column.
   
   2. Select the cells containing the values.
   
   3. Click the File tab.
   
   4. Click Options in the Backstage view. The Excel options dialog box opens.
   
   5. In the left pane of the dialog box, click Advanced.
   
   6. In the right pane, under General section, click the Edit custom lists.. button.

   • The Custom Lists dialog box opens.

   7. Click the Import button. The list of values gets added to the Custom lists box and the list items are displayed in the List entries box.
8. Click the OK button to close the Custom Lists dialog box.

9. Click the OK button to close the Excel Options dialog box.

(b) Excel provides various options to format numbers. You can add a currency symbol to the number, display it as a percentage or fraction and add or remove decimal places in the number. This is called number formatting. Various options available in the number format list are:

Accounting number format - To add a currency symbol and a decimal point to the number value.

Percent style - To multiply the number by 100 and display the number with a percentage sign.

Comma style - To add comma in a number as thousands separator.

Increase decimal - To increase the number of digits after the decimal point in the number.

Decrease decimal - To decrease the number of digits after the decimal point in the number.

(c) The TextWindow object provides various input and output methods. Four methods are;

1. WriteLine (): It displays text or number in the output window and shifts the cursor to the next line.

2. Write(): It displays text or number in the output window and keeps the cursor at the end of the same line.

3. Read(): It reads string values as input.

4. ReadNumber(): It reads numeric values as input.

(d) A stick figure is the representation of a person, animal, alphabet, digit or object. Parts of stick figures are Origin handle or orange handle and segment handle or red handle.
(e) Sprites are images that can be moved around, scaled or rotated in the same way as a stick figure. To load a sprite:

1. On the Menu bar, in the File menu, click Load Sprite image.
   • The Open dialog box opens.
2. Click the sprite you want to load to the animation.
3. Click the Open button. Pivot animator loads the selected sprite to the current frame of the animation.

(f) To compose and send an email using mail app:

1. In the Mail app, click + new mail. A message window opens.
2. In the To box, type the email address of the recipient.
3. In the Subject box, type a short description of the email message.
4. In the message area, type the message you want to send.
5. Use the formatting options at the top of the window to format the message.
6. Click the Send button. The Mail app sends your email message. A copy of the sent email message is stored in the Sent items folder.

---

**CYBER QUEST**

1. Web browser  
2. Insert  
3. Quick Tables  
4. Wrap Text  
5. Emphasis  
6. a moving dashed boundary  
7. xyz_abc@gmail.com  
8. 255  
9.  
10. Keywords  

11. 8  
12. 30  
13. Axe  
14. Joy  
15. Father  
16. 6  
17. 128  
18. 21  
19. III  
20. 47U15