Key to

ALL ABOUT COMPUTERS

PROGRESS PUBLISHERS
KRISHNA NAGAR, DELHI - 110051
EMAIL : progresspublishers@gmail.com
1. COMPUTER SOFTWARE


B. 1. hardware 2. compression 3. open source 4. antivirus 5. operating system


Language Processor – Assembler, Compiler, Interpreter

Application Software – Microsoft Word, Adobe Animate, Libre Office Calc, GIMP

E. 1. An Operating System is the basic software installed in a computer. It controls the way a computer works from the time it is turned ON till it is shut down. A computer is useless without an operating system. It serves as an interface between the user and the computer. Three functions of Operating system are:

(a) It controls the working of all hardware devices connected to the computer.

(b) It provides an environment for other software to be installed and executed.

(c) It manages various resources of the computer system such as memory, microprocessor and storage.

2. Utility Software – A Utility Software is a system software that enables a computer to work efficiently and perform its task better.

Some examples of utility software are :-

(a) Antivirus Software – An Antivirus Software is a utility software that protects the computer against harmful virus attacks. It scans hard disk and external media
attached to the computer for viruses and removes them. Eg - Norton Security, McAfee Total Protection.

(b) Disk Defragmenter Software – A Disk Defragmenter software combines all the parts of a file and places them at one location on the disk. This helps in faster loading of a file in memory. Eg - Diskeeper, MyDefrag.

(c) Backup Software – A Backup Software is used to make a duplicate copy of the data from a hard disk onto another storage device such as a DVD, Pen drive or NAS. It ensures that your data is not permanently lost in case of a system crash or virus attack.

3. Most software are written in high - level languages such as C++, Java or Visual Basic. But a computer understands only machine language in the form of bits (0 and 1). A language processor is a system software that converts a high-level language program into machine language program. So, language processors are important for computers.

4. A General Purpose Application software is used to perform the same set of tasks for a large number of users while a Customised Application Software is used to perform a specific set of tasks for an organization. It is developed according to the requirements and objectives of the organization.

5. (a) A spreadsheet software is used to enter data in a worksheet – made up of rows and columns. It also enables you to perform calculations on the data, represents in the form of charts and analyse the data.

(b) A DBMS software is used to create and manage database. It allows you to add, retrieve, search, sort and print information easily from a database.

(c) A multimedia software is used to create interactive applications by using text, images, audio, video and animation.
(d) A Graphics software is used to create and edit images such as photographs, posters, charts and logos.

Think and Answer
1. DTP
2. Compression Software

Crossword
Across:
4. Operating system
5. Utility
6. DBMS

Down:
1. Software
2. DTP
3. Antivirus

2. FEATURES OF WINDOWS 10
A. 1. Voice commands 2. Task view button
   3. + + 4. Search Box
   5. Windows Store
B. 1. On-Screen 2. Store
   3. Action Center 4. desktop
   5. Hey Cortana
D. 1. Windows Store 2. On Screen Virtual Keyboard
   3. Cortana 4. Tablet mode
   5. Action Center
E. 1. To move a program from one desktop to another :-
   (a) On the Taskbar, Click the Task View button.
      • Windows display thumbnails for each running program on the current desktop.
   (b) Right click the thumbnail of the program you want to move to another desktop.
      • A menu appears.
(c) Click Move to and select an option to move the program to an existing desktop or a new desktop.

- Windows moves the program to the selected desktop.

2. Cortana is a personal assistant in Windows 10. Cortana works well with voice based commands. You can speak to her and ask questions. She can open Programs, set appointments, manage email messages, give directions in maps, search for information in the computer and internet, and do much more.

3. Windows store is the online market place for various apps and games for Windows 10 users. You can download apps from the Windows Store, and install them in your computer. To access the windows store:

(a) Click the start button.
- The start button appears.

(b) Click the Store tile.
- The Store app opens and displays the Home page of the Windows store.

4. Two modes of working in a windows 10 desktop computer are Desktop Mode and Tablet Mode. To switch from one Mode to another:

(a) Click the Action center button on the Taskbar.
- The Action Center pane appears.

(b) Click the Tablet mode button.
- The computer switches to the tablet mode and displays start screen. The Tablet mode button in the Action center gets highlighted.

(c) Click the Tablet mode button again to switch to the Desktop mode. The desktop is displayed. The Tablet mode changes back to the original color.

5. You can switch between running programs in Windows 10 in three different ways.
(a) Switching between running programs using Taskbar
   • Move the mouse pointer over the icon of the program on the Taskbar you want to switch to.
   • Windows displays a thumbnail of the program window.
   • Click the thumbnail of the program. The program window appears.

(b) Switching between running programs using Task view
   • On the Taskbar, click the Task view button.
   Windows displays thumbnails of all running programs on the screen.
   • Click the thumbnail of the program you want to switch to.
   • The selected program window is displayed in the front.

(c) Switching between running programs using Keyboard
   • Press and hold the Alt Key.
   • Press Tab key to see the thumbnails of all running programs.
   • Press Tab key repeatedly until the thumbnail of the program you want to switch to is highlighted.
   • Release the Alt key. The selected program window is displayed in the front.

3. MORE FEATURES OF WORD 2016

A. 1. Hanging indentation  
    2. Find and Replace 
    3. Official 
    4. Page Margin 
    5. Left

B. 1. Find 
    2. paragraph 
    3. center 
    4. Portrait 
    5. Line

C. 1.T  
    2. T  
    3. F  
    4. T  
    5. F

D. 1. To Find and Replace all occurrences of a word in a document:
   (a) On the Home tab, in the Editing group, click Replace.
• The find and replace dialog box opens with the Replace tab selected.

(b) In the Find what text box, type the text you want to replace.

c) In the Replace with text box, type the new text with which you want to replace the text typed in the Find what text box.

d) Click the Find Next button.

• Word finds the first occurrence of the text to replace and highlights it.

(e) Click the Replace All button.

(f) Click the OK button to close the dialog box.

(g) Click the close button to close the Find and Replace dialog box.

2. Indentation is the process of setting text of a line at a specified position from the page margins. Word 2016 offers four indentation options to format a paragraph.

<table>
<thead>
<tr>
<th>Left Indentation</th>
<th>It sets the position of all lines in a paragraph from the left page margin.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right Indentation</td>
<td>It sets the position of all lines in a paragraph from the right page margin.</td>
</tr>
<tr>
<td>First Line Indentation</td>
<td>It sets the position of the first line of a paragraph from the left page margin, keeping all other lines with the left margin.</td>
</tr>
<tr>
<td>Hanging Indentation</td>
<td>It sets the position of all lines of a paragraph, except the first line, from the left page margin.</td>
</tr>
</tbody>
</table>
3. Page orientation is the page layout in which a document is displayed or printed.

Word offers two page orientation options:

- Portrait orientation displays the page vertically and the document is printed length wise.
- Landscape orientation displays the page horizontally and the document is printed width wise.

4. Page margins are the blank spaces between the edge of the page and the text of a document on all the four sides. By default, word assigns one inch margin all around a page in a document.

To set predefined page margins:

(a) On the Layout tab, in the Page Setup group, click the margins button.
   • A drop down list appears which displays a list of predefined margin settings.

(b) Click a desired margin setting.
   Word applies the new margin setting to the page.

To set custom page margins:

(a) On the Layout tab, in the Page Setup group, click the Margins button.
   • A drop down list appears.

(b) Click Custom Margins.
   • The Page Setup dialog box appears.

(c) On the Margins tab, in the Margins section, specify values for top, bottom, left and right margins.

(d) Click the OK button.
   • Word applies the new margin settings to the page.

5. To add borders around a page in a word document:

(a) On the Design tab, in the Page Background group, click the Page Borders button.
   • The Borders and shading dialog box opens with the Page Border tab selected.
(b) In the Setting section, click the type of border you want to apply to the document.

(c) Select the border style, color and width from the Style, Color and Width list boxes respectively. You can also select a predefined artistic border style from the Art list box. Word displays a sample of the selected border option in the preview section.

(d) Click the OK button.

Word applies the selected border to all pages in a document.

6. A column is a vertical division of text on a page. To arrange text in two columns:

(a) Select the text you want to arrange in columns.

(b) On the Layout tab, in the Page Setup group, click the Columns button.

- A drop-down list appears which displays predefined column layouts.

(c) Click the column layout Two.

- Word displays the selected text in two column layout.

7. To print a document in word:

(a) Click the File tab.

- The Backstage view appears.

(b) Click Print.

- The Print page appears.

  It displays a preview of the document on the right side. It provides options for printing the document on the left side.

(c) Click the arrows (◀ and ▶) to preview different pages in the document.

(d) Drag the Zoom slider to increase or decrease the page view area.

(e) Under Printer, select a printer from the list of installed printers.
(f) In the Copies box, specify the number of copies you want to print.

(g) Under settings:

(i) Click the down arrow next to Print all pages to open a list of page options.

- Select Print All pages to print the entire document.
- Select Print Selection to print selected text in the document.
- Select Print Current Page to print the page that is currently shown in the preview pane.
- Select Custom Print, and in the pages box, specify page numbers or a range of page numbers you want to print.

(ii) Select orientation and page size from the Orientation and Size box respectively.

(iii) Select any additional setting from the drop down lists, if needed.

(h) Click the Print button. Word prints the document as per the selected options.

E. 1. Find 2. Landscape
3. A4 4. Layout

Think and Answer

1. Custom print
2. To correct the spelling of a particular word in complete document, Jacob should use Find and Replace all option.

4. OBJECTS IN WORD 2016

A. 1. Text 2. Shape Fill
3. Artistic Effects 4. Symbols Gallery
5. [Weight]

B. 1. Wrap Text 2. Format
3. Illustrations 4. WordArt
5. Graphics
D. 1. To insert a picture stored in computer:
   (a) Click the location in the document where you want to insert the picture.
   (b) On the Insert tab, in the Illustrations group, click the Pictures button.
      • The Insert Picture dialog box opens.
   (c) Navigate to the folder where your picture is located and select the picture you want to insert.
   (d) Click the Insert button.
      • The picture appears in the document. It is surrounded by a boundary. You can use the handles around the boundary to resize and rotate the picture.
   (e) Click anywhere outside the picture to insert it in the document.

2. Symbols are special such as copyright sign © and rupee symbol ₹.
   • To insert a symbol in a document :-
   (a) Click the location in the document where you want to insert a symbol.
   (b) On the Insert tab, in the Symbols group, click the Symbol button.
      • The Symbol gallery appears.
   (c) Click a symbol in the gallery to insert it in the document.
   (d) If the symbol does not appear in the gallery, click More symbols. The Symbol dialog box opens.
   (e) Select a font from the Font drop-down list.
   (f) Scroll through the list of symbols and select the symbol you want to use.
   (g) Click the insert button. Word inserts the selected symbol in the document.
   (h) Click the Close X button to close the Symbol dialog box.
3. To insert a screenshot of an app window in a document:
(a) Open the app window of which you want to insert the screenshot in the document.
(b) Resize the window as you want to display it in the document.
(c) Switch to Word and click the location in the document where you want to insert the screenshot.
(d) On the Insert tab, in the Illustrations group, click Screenshot button.
   • The Screenshot menu appears which displays the thumbnails of all the windows that are currently open.
(e) Click the thumbnail of the window you want to insert in the document.
   • Word inserts the screenshots of the selected window in the document.

4. WordArt is a feature in Word 2016 that allows you to create stylised text. To convert existing text into a WordArt object:
(a) Select the text you want to convert into a WordArt object.
(b) On the Insert tab, in the Text group, click the WordArt button.
   • The WordArt gallery appears.
(c) Choose a WordArt style from the gallery. The selected text is converted into a WordArt object.

5. Cropping a picture means to remove unwanted part of a picture. To crop a picture:
(a) Select a picture.
(b) On the Picture Tool Format tab, in the Size group, click the Crop button.
   • Thick black handles appear around the picture.
(c) Drag the handles to mark the area you want to keep.
• The areas that will be excluded from the cropped picture appear shaded.
(d) Click anywhere outside the picture or click the Crop button again.
• Word crops the picture as per your selection.

6. To apply WordArt styles to a WordArt objects:
(a) Select a WordArt object.
(b) On the Drawings Tools Format tab, in the WordArt Styles group, click the More button.
• The WordArt Styles gallery appears.
(c) Move the mouse pointer over a style to preview it on the WordArt object.
(d) Click the WordArt style you want to apply.
• Word applies the selected style to the WordArt object.

7. To insert a shape in a document:
(a) On the Insert tab, in the Illustrations group, click the Shapes button. The Shapes gallery appears.
(b) Click the shape you want to insert.
(c) Move the mouse pointer to the document area. The pointer changes to a thin + sign.
(d) Click and drag the mouse to draw the shape.
• The shape is surrounded by a boundary to indicate that it is selected. You can use the handles to resize and rotate the shape.
(e) Click anywhere outside the shape to insert it in the document.

Formatting features that can be applied on the inserted shape are:
(a) Shape fill       (b) Shape outline
(c) Shape effects    (d) Shape styles

**Think and Answer**
1. Samuel should use Text Wrap feature.
2. Lily should use Picture Effects feature.
5. INTRODUCTION TO SCRATCH

A. 1. Project  
   2.  
   3. Looks blocks  
   4. brown  
   5.  

B. 1. Motion  
   2. Blocks  
   3. Scrips area  
   4. forever  
   5. sprite  

C. 1.F  
   2. T  
   3. T  
   4. T  
   5. F  

D.  
   Bounces the sprite in the opposite direction when it touches an edge of the stage.  
   Executes a script when the green flag button is clicked.  
   Displays a speech bubble above the selected sprite for specified time.  
   Repeats the enclosed block for a specified number of times.  

E. 1. Scratch is an educational programming language developed by Massachusetts Institute of Technology (MIT) Media Lab.  
   Features of Scratch are:  
   • It is easy to learn and use.  
   • It helps you to learn basics of programming in a fun manner.  
   • It provides a graphical environment where you can create a project by joining various blocks together.  
   • It allows you to create beautiful greeting cards, animated stories and games using various characters.  
   • It allows you to share your projects with other Scratch users around the world.  
   2. The various blocks in the Blocks Palette can be divided into three main types:
(a) Stack Blocks: Stack blocks have notches at the top and bottom such as move 10 steps. These blocks can be snapped together to form a stack of blocks.

(b) Hat Blocks: Hat blocks have rounded tops, such as [image]. They are placed at the top of a stack of blocks. Hat blocks wait for an event to happen, such as a key press or mouse click, and then execute the blocks underneath them.

(c) Reporter Blocks: Reporter Blocks are designed to fit in the input area of other blocks. These blocks come in two shapes – Pointed ends or rounded ends and fit into blocks having input area of the same shape.

3. The stage is the area where sprites move and interact with each other in a project. It is 480 pixels wide and 360 pixels tall. It is divided into x and y coordinates. The middle of the stage has x coordinate 0 and y coordinate 0. The x and y of the current mouse position are displayed at the bottom right corner of the stage.

The green flag button is used to start the execution of a project.

The Stop button is used to stop the execution of a project.

4. There are five cursor tools that help to perform various actions.
   - Duplicate: To create duplicate copy of a sprite or block.
   - Delete: To delete a sprite or block.
   - Grow: To increase the size of a sprite.
   - Shrink: To decrease the size of a sprite.
   - Block help: To view a description of a block in the Tips pane.

5. The Looks blocks are used to change the appearance of a sprite, and make it speak and think. These blocks are color coded purple.
The Events blocks are used to sense events, which trigger scripts to run. These blocks are color coded brown.

6. MORE ON SCRATCH

A. 1. 2. 3. 4. Sensing

B. 1. animation 2. light blue 3. backdrop 4. Costumes 5. dark green


D. 1. The background of the stage is called the Backdrop. By default, the stage has a white backdrop.

   To add backdrop of your own:
   (a) In the Backdrop pane, click the Paint new backdrop button.

     • The Paint Editor opens under the Backdrops tab.

   (b) Draw a backdrop using various tools in the Paint Editor.

     • The selected backdrop is displayed on the Stage and is added to the Backdrop list.

2. A costume is a specific appearance for a sprite. The costume tab displays all the costumes for the selected sprite. Different costumes in a sprite are used to create animation by quickly changing the costume of a sprite.

3. The Sound blocks are used to play sounds. These blocks are colour-coded bright purple while the Sound tab displays all sounds for a selected sprite. By default, the cat sprite has one sound – meow.

4. To add a new sprite to a project :-

   (a) In the Sprites pane, click the Choose sprite from library button.
• The Sprite library opens. It displays various sprites group under different categories and themes.

(b) Click the sprite you want to add to your project.

(c) Click the OK button.

• The selected sprite appears on the stage and its thumbnail is added to the sprites list.

5. The Pen blocks are used to draw on the stage using the sprite as a pen. These blocks are colour-coded dark green. Clear block is used to clear all pen marks and stamps from the stage. Pen up block is used to pull the pen of the sprite up, so that it does not draw as it moves.

### 7. MORE ON POWERPOINT 2016

A. 1. Notes Page  2. design template  
   3. Theme  4. 🎨 From Current Slide  
   5. presentation

   4. Reading  5. Variants


D. 1. To add slides from an existing presentation to the current presentation:
   (a) In the Thumbnails pane, click the slide after which you want to insert the new slide.

(b) On the Home tab, in the Slides group, click the New Slide down arrow.
   • A drop-down menu appears.

(c) Click Reuse slides.
   • The Reuse slides pane opens on the right side of the PowerPoint window.

(d) Under Insert slide from, click the Browse button and select Browse file.
• The browse dialog box opens.

(e) Select the presentation from which you want to use
the slides and click the open button.

• The Reuse Slides pane displays thumbnails of the
available slides.

(f) Click the thumbnail of the slide you want to insert in
your presentation.

• PowerPoint inserts the selected slide you want to insert
in presentation.

(g) Click the close X button to close the reuse slides pane.

2. To apply a gradient background colour to a slide:

• Click Gradient fill.

• Click the Preset gradients button and select a
gradient from the palette.

3. Various print layout options available for printing a
presentation are:

(a) Full page slides: To print each slide on a full page.

(b) Notes pages: To print each slide along with any
speaker notes.

(c) Outline: To print text outline of the entire presentation.

(d) Handouts: To print thumbnails of one or more slides
on a page.

4. To create a new presentation from a design template:

(a) Click the File tab.

• The backstage view opens.

(b) Click New.

The thumbnail of various design templates are
displayed.

(c) Click the thumbnail of a template.

A preview window opens. It displays the title slide of
the selected template with alternative color schemes
and backgrounds.
(d) You can:
   i. Click the more images arrows to preview other slide layouts for the template.
   ii. Click a thumbnail in the right half of the preview window to preview slide layouts with the selected color scheme and background.
   iii. Click the arrows to the left and right of the preview window to preview other design templates.

(e) Click the Create button. PowerPoint creates a new presentation based on the selected design template.

5. Color, font and effect elements can be modified in a presentation. To change the font scheme of the theme:

(a) On the Design tab, in the Variants group, click the More Button.
   
   - The Variants menu appears. It displays various options to change the colour, font and effect of a theme.

(b) To change the font scheme of the theme, click Fonts and select the desired font set.

(c) PowerPoint modifies the theme as per your selection.

Think and Answer

1. She can do so by using Modifying Theme Elements option

2. Notes Page View

8. OBJECTS IN POWERPOINT 2016

A. 1. + sign        2. Text Box
    3. SmartArt Styles 4. Promote
    5. Drawing Tools Format Tab

B. 1. shape        2. Photo Album
    3. Illustrations 4. style
    5. Design

D. 1. SmartArt Graphics are diagrams that you use to visually communicate information in an interesting and easily understandable manner. They are grouped under various categories – list, process, cycle, hierarchy, relationship, matrix, pyramid, picture and office.com.

2. A text box is used to add a text placeholder of your own in a slide. You can place a text box anywhere on the slide. To insert a text box:

(a) On the Insert tab, in the Text group, click the Text Box button.

(b) Move the mouse pointer at the location where you want to add the text box.

(c) Click and drag on the slide to draw the text box. The text box appears with a dotted boundary and the cursor blinks inside it.

(d) Type the required text.

(e) Format the text in the text box as you format normal text.

(f) Click anywhere outside the text box. PowerPoint inserts the text box in the slide.

3. To insert a shape in a slide:

(a) On the Insert tab, in the Illustrations group, click the Shapes button.

   • The shapes gallery appears.

(b) Click the shape you want to use. The pointer changes to a thin plus + sign.

(c) Click and drag on the slide to draw the shape of required size.

   • The shape appears in the slide with a boundary around it. Use the handles around the boundary to resize or rotate the shape.

(d) Type the text you want to add to the shape.
4. Various options available to modify the structure of SmartArt Graphics are:
   Add shape – to add a new shape to the graphic at a desired level.
   Promote – To increase the level of a selected shape.
   Demote – To decrease the level of a selected shape.
   Move up or move down – To change the order of a selected shape.
   Right to left – To switch the layout of the SmartArt graphic between left to right and right ot left.

5. To create a photo album presentation:
   (a) On the Insert tab, in the Images group, click the Photo Album button. The Photo Album dialog box opens.
   (b) Click the File / Disk button.
       • The Insert New Pictures dialog box opens.
   (c) Select all the pictures you want to include in your photo album.
   (d) Click the Insert button.
       • The selected pictures are added to the Pictures in album list in the Photo Album Dialog box.
   (e) In the album layout section:
       i. Click the Picture layout down arrow and select a layout style for the pictures.
       ii. Click the Frame shape down arrow and select a frame for the pictures.
       iii. Click the Browse button and select a theme for the album from the Choose Theme dialog box.
   (f) Click the create button.
       • PowerPoint creates the photo album presentation.
9. INTRODUCTION TO EXCEL 2016

A. 1. .xlsx 2. 16384 3. Active Cell 4. One 5. Name Box

B. 1. worksheet 2. 1048576 3. Ctrl + O 4. formula bar 5. cell


E. 1. A workbook contains one or more pages called worksheets. A worksheet consists of a series of rows and columns. Some other spreadsheet software are Libre office and Kingsoft spreadsheets.

2. Features of Excel 2016 are :-

   Excel 2016 lets you.
   
   (a) Organise data in multiple worksheets in a workbook.
   (b) Enter data in a variety of formats such as text, numbers and formulas.
   (c) Edit and format data in different ways.
   (d) Recalculate all the formulae whenever a related number or a value is changed.
(e) Perform automated calculations using predefined functions.

3. A file in Excel is called a workbook. Each workbook contains one or more pages called worksheets. A worksheet consists of a series of rows and columns.

4. To save an untitled workbook:
(a) Click the File tab. The Backstage view opens.
(b) Click Save. The Save As page appears.
(c) Click the Browse button. The Save As dialog box opens.
(d) Select the location where you want to save the workbook.
(e) Enter a name for the workbook in the File name box.
(f) Click the save button. Excel saves the workbook and its name appears on the title bar.

5. Two ways to select the cell range:
(1) Click the first cell in the range.
   • Click and drag the mouse pointer to the last cell in the range.

   OR

(2) Press and hold the shift key and click the last cell in the range.

Think and Answer
1. Raghav can select it by selecting multiple cell ranges. To select multiple cell ranges:
   (a) Select the first cell range.
   (b) Hold the Ctrl key and select another cell range. All the selected cell ranges appear highlighted

2. To rename a worksheet:
   (a) Click the tab of the worksheet you want to rename.
   (b) On the Home tab, in the Cells group, click the down arrow under Format.
   • A drop-down list appears.
(c) Under Organize sheets, click Rename sheet. The worksheet name appears highlighted.
(d) Type a New name for the worksheet.
(e) Press Enter.
   • Excel assigns a new name to the worksheet.

---

10. BROWSING THE INTERNET

A. 1. Home Page   2. Browser window
   3. URL          4. Start Tab
   5. Web pages

B. 1. Favorites   2. web browser
   3. eraser       4. Reading view
   5. website


D. 1. Microsoft Edge allows you to make notes, write, doodle and highlight directly on web pages. These are called web notes. Different tools to work with web notes are:
   • Pen - to write and draw in different colours and thickness.
   • Highlighter - to highlight text in different colours.
   • Eraser - to remove lines, text or clear all ink from the web note.
   • Add a typed note - to add notes or comments in a text box.
   • Clip - to clip a specific area from the web page.
   • Save web note - to save the web note in OneNote, favorites or Reading list.
   • Share web note - to share a web note with others through messaging or other apps.
   • Exit - to close the web notes toolbar and return to the original web page.
2. Steps to use Cortana to get more information about text in a web page:
(a) Open a web page in Edge.
(b) Select the text on which you want more information.
(c) Right-click the selected text.
   • A menu appears
(d) Click Ask Cortana.
   • A pane appears on the right side of the browser window and displays the information about the selected text.
(e) Click anywhere outside the pane to close it.
3. To set a home page in Microsoft edge :-
(a) Click the More button.
   A menu appears.
(b) Click Settings.
   The settings pane appears.
(c) Under Open with, click the A specific page or pages option.
(d) Click the page list and select Custom.
(e) Click the cross X button to remove the start page.
(f) Type the URL of the desired home page into the Enter a web address box.
(g) Click the Plus + button. The new home page will appear the next time you launch Edge.
4. Microsoft Edge has a feature Reading view which allows you to read web pages without any distractions. It removes unnecessary elements such as banners, advertisements and other pop ups from a web page and allows you to read an article clearly. To view a web page in Reading view:
(a) Open a web page.
(b) Click the Reading view button in the address bar. The web page reappears without any unnecessary page elements.
(c) Click the Reading view button again to return to the normal view of the web page.

5. The Hub is the place where Edge keeps the things you collect on the web. It provides access to your favorite web pages, reading list, browsing history and downloads.

To save a web page as Favorite :-
(a) Navigate to a web page you want to add to Favorite list.
(b) Click the Favorites button in the address bar. The Favorite dialog box appears.
(c) Type a name for the web page and click Add button. The URL of the web page gets added to your Favorite list.

11. ALGORITHM AND FLOWCHART

A. 1. Off page connector 2. Program 3. 4. 5. Top to Bottom
B. 1. flowchart 2. terminal 3. algorithm 4. loop 5. flow lines
D. 1. An algorithm is a systematic and logical procedure for solving a problem. It is written in a simple language so that one can easily understand the steps. A good algorithm helps us to write effective and efficient programs.

All About Computers - 5
2. A flowchart is a pictorial or diagrammatic representation of an algorithm. It uses geometric symbols to represent various operations. Each symbol is used for a specific purpose in a flowchart.

The various symbols used to draw a flowchart are:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Symbol Name</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Start/Stop Box or Terminal Box</td>
</tr>
<tr>
<td></td>
<td>Process Box</td>
</tr>
<tr>
<td></td>
<td>Input/Output Box</td>
</tr>
<tr>
<td></td>
<td>Decision Box</td>
</tr>
<tr>
<td></td>
<td>Flow Lines</td>
</tr>
<tr>
<td></td>
<td>On page connector</td>
</tr>
<tr>
<td></td>
<td>Off page connector</td>
</tr>
</tbody>
</table>

3. Rules to draw a flowchart are:
   - A flowchart should be clear, neat and easy to follow.
   - A flowchart is generally drawn from top to bottom, or from left to right.
   - A flowchart must have a Start box and a stop box.
   - Only one flow line should come out from a process or input/output box.
   - Only one flow line should go in a decision box, but two flow lines, one for each possible answer, should come out from the decision box.
   - Two flow lines cannot intersect each other in a flowchart.

4. A loop is a set of instructions that repeats itself continuously until a particular condition is satisfied. A loop is used when a process needs to be repeated a
certain number of times or until a certain condition is achieved.

5. The use of various symbols to draw a flowchart are:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Oval</td>
<td>to indicate the beginning and end of flowchart.</td>
</tr>
<tr>
<td>Rectangle</td>
<td>to represent a process or action.</td>
</tr>
<tr>
<td>Parallelogram</td>
<td>to obtain input and display output.</td>
</tr>
<tr>
<td>Diamond</td>
<td>to test a condition and take a decision based on its result.</td>
</tr>
<tr>
<td>Arrow lines</td>
<td>to indicate the direction of operations in a flowchart.</td>
</tr>
<tr>
<td>Circle</td>
<td>to connect parts of a flowchart within a page.</td>
</tr>
<tr>
<td>Polygon</td>
<td>to connect parts of a flowchart on different pages.</td>
</tr>
</tbody>
</table>

E. 1. To start a computer:

Algorithm

```
Step 1  :  Switch ON the Main Power Supply.
Step 2  :  Switch ON the UPS.
Step 3  :  Switch ON the CPU.
Step 4  :  Switch ON the Monitor.
```

Flowchart

```
Start

Switch ON the main power supply

Switch ON the UPS

Switch ON the CPU

Switch ON the Monitor

Stop
```
2. To calculate and print the area and perimeter of a square:

**Algorithm**

Step 1: Input the side of a square.
Step 2: Area = Side \times Side.
Step 3: Perimeter = 4 \times Side.
Step 4: PRINT Area.
Step 5: PRINT Perimeter.

**Flowchart**
3. To print numbers from 1 to 20 :-
(Use N instead of number)

Algorithm

Step 1 : Number = 1.
Step 2 : PRINT Number.
Step 3 : Number = Number + 1.
Step 4 : If Number is > 20, Print Number.
        else, stop

Flowchart

Start

N = 1

PRINT N

N = N + 1

IS

N < 20

Yes

NO

Stop
4. To input marks of a student in five subjects and display the total and average marks:

**Algorithm**

Step 1: Enter marks of 5 subjects - A, B, C, D, E.
Step 2: SUM = A + B + C + D + E.
Step 3: AVERAGE = \( \frac{SUM}{5} \).
Step 4: PRINT SUM.
Step 5: PRINT AVERAGE.

**Flowchart**
Test your skill

1. 28, 33, 40
2. 

Start

Read L, B

Area = L \times B

Print Area

Perimeter = 2(L+B)

Print Perimeter

Stop

---

**ASSESSMENT SHEET – 1**

1. a. DTP software b. Looks
c. Desktop Mode d. Artistic effects
e. Open Source Software

2. a. Antivirus b. Backdrop
c. Action Center d. Portrait Orientation
e. Motion

3. a. T b. F c. T d. F e. F
4. | Block       | Category | Function                                                                 |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>![pen down]</td>
<td></td>
<td>Puts the pen of the sprite down, so that it draws as it moves.</td>
</tr>
<tr>
<td>![forever]</td>
<td></td>
<td>Repeat the enclosed blocks until the program is stopped.</td>
</tr>
<tr>
<td>![when space=key pressed]</td>
<td></td>
<td>Executes the script when a specific key on the keyboard is pressed.</td>
</tr>
<tr>
<td>![turn n degrees]</td>
<td></td>
<td>Turns the sprite by ‘n’ degrees anticlockwise.</td>
</tr>
<tr>
<td>![play sound meow until done]</td>
<td></td>
<td>Plays a specified sound till it ends and then move to the next block.</td>
</tr>
<tr>
<td>![switch costume to costume2]</td>
<td></td>
<td>Changes the costume of a sprite to a specified costume.</td>
</tr>
</tbody>
</table>

5. (a) Operating system          (b) Task View
(c) Hat Blocks                (d) Scripts Area
(e) Disk Defragmenter Software

6. (a) An Operating System is the basic software installed in a computer. It controls the way a computer works from the time it is turned ON till it is shut down. A computer is useless without an operating system. It manages all the other software installed in a computer. It serves as an interface between the user and the computer. Three functions of Operating system are:

1. It controls the working of all hardware devices connected to the computer.
2. It provides an environment for other software to be installed and executed.
3. It manages various resources of the computer system such as memory, microprocessor and storage.

(b) To move a running app from one desktop to another:-
1. On the Taskbar, Click the Task View button. Windows display thumbnails for each running program on the current desktop.

2. Right-click the thumbnail of the program you want to move to another desktop.
   A menu appears.

3. Click Move to and select an option to move the program to an existing desktop or a new desktop. Windows moves the app to the selected desktop.

(c) Page orientation is the page layout in which a document is displayed or printed.

   Word offers two page orientation options:

1. Portrait orientation displays the page vertically and the document is printed length-wise.

2. Landscape orientation displays the page horizontally and the document is printed width-wise.

(d) A Utility Software is a system software that enables a computer to work efficiently and perform its task better. Some utility software are :

1. Antivirus Software – An Antivirus Software is a utility software that protects the computer against harmful virus attacks, It scans hard disk and external media attached to the computer for viruses and removes them.

2. Disk Defragmenter Software – A Disk Defragmenter Software combines all the parts of a file and places them at one location on the disk. This helps in faster loading of a file in memory.
(e) The background of the stage in scratch is called the Backdrop.

To add a new backdrop :-

1. In the Backdrop pane, click the Choose backdrop from library button.

   The Backdrop library opens. It displays various backdrops grouped under different categories and themes.

2. Click the backdrop you want to use.

3. Click the OK button. The selected backdrop is displayed on the Stage. Its thumbnail is displayed in the backdrop pane and is also added to the backdrops list.

(f) Cropping a picture means to remove unwanted part of a picture. To crop a picture:

1. Select a picture.

2. On the Picture Tool Format tab, in the Size group, click the Crop button. Thick black handles appear around the picture.

3. Drag the handles to mark the area you want to keep.
   • The areas that will be excluded from the cropped picture appear shaded.

4. Click anywhere outside the picture or click the Crop button again. Word crops the picture as per your selection.
1. (a) Web Browser  (b) one  
   (c) Reading View  (d) Rectangle  
   (e) shape 

2. (a) Algorithm  (b) terminal  
   (c) URL  (d) Hub  
   (e) Slider Sorter 

3. (a) F  (b) F  (c) F  (d) T  (e) F 

4. (a) C5  
   (b) Click the cell E3 then click and drag mouse pointer to the cell E11.  
   (c) Ctrl  
   (d) Name box  
   (e) .xlsx 

5. (a) Off page connector  
   (b) Design Template  
   (c) Flow lines  
   (d) Spreadsheet  
   (e) Home page 

6. (a) A loop is a set of instructions that repeats itself continuously until a particular condition is satisfied. A loop is used when a process needs to be repeated a certain number of times or until a certain condition is achieved.
(b) Each cell has a unique address, formed by a combination of its column label and row number, called its cell reference. A cell reference is written as the intersection of a column and a row, e.g. intersection of column B and row 4 is B4.

(c) To save a web page in Favorite list:-
1. Navigate to a web page you want to add to favorite list.
2. Click the Favorites button in the address bar. The Favorite dialog box appears.
3. Type a name for the web page and click Add button. The URL of the web page gets added to your favorite list.

To open a web page from favorites list:
1. Click the Hub button.
   • The Hub pane opens.
2. Click the Favorites tab.
   • A list of your saved web pages appears.
3. Click the web page you want to open.
   The Web page opens in the current tab.

(d) Rules to draw a flowchart are:
• A flowchart should be clear, neat and easy to follow.
• A flowchart generally drawn from top to bottom, or from left to right.
• A flowchart must have a Start box and a Stop box.
• Only one flow line should come out from a process or input/output box.
• Only one flow line should go in a decision box, but two flow lines, one for each possible answer, should come out from the decision box.

• Two flowlines cannot intersect each other in a flowchart.

(e) SmartArt graphics are diagrams that you use to visually communicate information in an interesting and easily understandable manner. They are grouped under various categories – list, process, cycle, hierarchy, relationship, matrix, pyramid, picture, and Office.com. Every SmartArt graphic is made up of one or more shapes.

(f) The purpose of inserting a text box in a slide is to add a text placeholder of your own in a slide.

---

**CYBER QUEST**

1. Norton
2. Hat Blocks
3. Create a photo album
4. 1048576
5. 📁
6. Office
7. 🔐 + Ctrl + D
8. WordArt
9. Windows 10
10. Microsoft Edge
11. OCPMTURE
12. 8
13. 69300
14. 20
15. 8
16. LXXXIX
17. 180
18. 
19. 6042680
20. 6 hr 30 min